Problem calibrating RTL stick


#21

I tried scanning the GSM850 band and if didn’t find a single signal.


#22

I think you are right. I think that I’ve done so much fiddling with this right now that I might as well zap it back to the initial install and start again.


#23

Hello again,

now things got even worse :fearful: I can see in the client that the tracking jobs start and finish BUT on SatNOGs page (e.g. https://network.satnogs.org/observations/156928/) I only get “Waiting for waterfall” and no data appear.
Note that up until yesterday it was working… Do you know where are the tracking data stored locally in the RPi?

Thanks


#24

Data are stored in /tmp/.satnogs/data by default.

Also you can check the logs to see if there is any error. For logs run sudo journalctl -u satnogs-client.service


#25

Thanks Fredy!

There is no error in the logs; however, /tmp/.satnogs is not changing is size. Additionally, /tmp/.satnogs/data/incomplete is empty and remains empty while tracking takes place.

One solution would be to reinstall the image from scratch. Since it is not easy physically access the RPi, is there a way to remove and then re-install the SatNOGS Client software, while keeping the same image running?

Thanks


#26

During a pass you should see the data in /tmp/.satnogs/data except if it was set otherwise in satnogs-setup. If not there should be an error in logs, interesting you don’t get any. :confused:

For re-installing client you can select Reset option from satnogs-setup interface. Just have in mind that this option will reset any saved settings, so you will need to add them again.


#27

What GAIN values I must use with a standard RTL-SDR without external preamp?
Same here, no good results with RTL-SDR + eggbeater…

Thanks 73’s


#28

@ea5wa

The available values for RF-GAIN of rtl-sdr can be found at https://wiki.satnogs.org/SatNOGS_Client_Ansible#Advanced_Setup.

The best gain it depends on the station and the rf noise around it. So, it will need some experiments before you find the best gain for your setup. First try to get some noisy satellites like NOAA in VHF or FOX-1s and then after having a couple of gains try other ones with “weak” signals.


#29

I select RFGAIN as 48 but I see no difference…

Is there any way to check what are the present settings in my system?

Thanks


#30

I guess you use the raspberry pi image.

By running sudo satnogs-setup you will get the menu, there you should see an option saying Show Show configuration file. Select it and you will see all the set variables, including rf gain.

Have you tried other values, other than 48? I would suggest for starting with some lower values like 25.4 or 29.7.


#31

And for IF GAIN and BB GAIN, what values should I try?

Thanks


#32

For rtl-sdr these gains don’t play any role.


#33

Trying to install kalibrate-rtl, but when I make ./bootstrap, I have:

line 6: aclocal:command not found
line 7: autoconf: command not found
line 8; autoheader: command not found
line 9: automake: command not found

What should I do?

Thanks


#34

I installed automake and now is working perfectly…


#35

weird because it looks like you just need “.” inside path. In bash, type:
PATH=.:$PATH