PlutoSDR support

Little add to the text above: With the Pluto not plugged into the Pi I get the same result.

Have you set up udev rules for pluto?

did not, have now, removed the Pluto, plugged it back in, rebooted the Pi, now testing.



Sorry but that made no difference.
Apr 21 16:25:51 raspberrypi satnogs-client[313]: RuntimeError: SoapySDR::Device::make() no match

Have you installed soapy-plutosdr lib?

They provide debs also

Yes, I have, the detection utility at the end of the instructions detects the Pluto, I can run it as server on the Pi and connect to it remotely from SoapySDR on windows machine.

Hi all, I ran into exactly the same issues as Ben.
Has there been a solution in the meantime?
Thank you!


1 Like

Hi everybody,
just doing some tests with my Plutosdr, but now way, neither in a simple gnuradio flowgraph nor with this:

When started the previous code I obtain:

satnogs@raspberrypi:/home/pi $ --soapy-rx-device=“driver=plutosdr” --rx-freq=433e6 --samp-rate-rx=2e6 --antenna=A_BALANCED
[INFO] Opening plutosdr #0…
[ERROR] Unable to set BB rate.
[INFO] Auto setting Buffer Size: 536870912
… and so on the same …

… and I’ve to stop the flowgraph by keyboard

Any infos??? I’m planning an SatNOGS station dedicated to L / S band, so the Plutosdr!

Tnx in advance,


EDIT: killing the running app kills the Plutosdr too! power cycle to get it back…

Yes, months later … but I am also about to set up an S-band GS using Pluto. Was this issue solved to everybody’s satisfaction?
Cheers, David.

No, unfortunately, at least based on my latest testing over the past two weeks.
At the moment I’m trying a Hackrf, that works, but that has other problems: high intrinsic noise / need of an external 10 MHz reference… I’m working on it :face_with_raised_eyebrow: :grinning_face_with_smiling_eyes:

Victor I3VFJ

Hi Victor,
The current SatNOGS ‘Software defined Radio’ page here still treats the HackRF as technically unsupported, but with some progress being made. You could update the Wiki page if you have managed to get it working reliably.

With regard to the Pluto, I met all sorts of problems during installation of the Soapy module - missing dependencies, wrong paths in scripts, insufficient directory read/write/execute permissions etc. Using this receiver is not for the faint-hearted! I also get the “SoapySDR::Device::make() no match” error … and hoping that someone will find an answer to the problem before I do !

1 Like

If someone wants to debug the PlutoSDR support but is lacking the hardware, there is the SDR Testbed, providing real hardware (running 24/7 in to interested projects via a Gitlab runner. See the presentation by @Acinonyx in the linked repo.

Fabian / kerel