Newbie in test mode, but no data captured

Hello, I am a newbie. I have setup Pi and SDR as instructed all is well and showing in test mode on the network, but I am not capturing any data. I have entered config advanced and this is the result of the support file, I do not understand the errors, could you give me some advice please, Is it possible to display wether the SDR is receiving any data please.

Generating support report. Please wait…
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/apt/”, line 90, in enter
return self._lock.enter()
apt_pkg.Error: E:Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/var/lib/satnogs-config/bin/satnogs-config”, line 8, in
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/”, line 29, in main
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/”, line 258, in show
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/”, line 478, in _support
).dump(indent=4) +
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/helpers/”, line 87, in dump
return json.dumps(, *args, **kwargs)
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/helpers/”, line 66, in info
“pending-updates”: apt.has_updates(),
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/helpers/”, line 16, in has_updates
File “/usr/lib/python3/dist-packages/apt/”, line 567, in update
with _WrappedLock(apt_pkg.config.find_dir(“Dir::State::Lists”)):
File “/usr/lib/python3/dist-packages/apt/”, line 93, in enter
(self._path, e))
apt.cache.LockFailedException: Failed to lock directory /var/lib/apt/lists/: E:Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
pi@raspberrypi:~ $

It looks like it doesn’t have access to get the lock needed for generating the report. My guess is that instead of sudo satnogs-setup you ran just satnogs-setup. Let us know if your issue is solved by running sudo satnogs-setup.

any update on the issue? Did you manage to solve it?

I just started experiencing this lock error also. Everything was running fine, rotctld and rigctld. Noticed my inexpensive rtl-sdr frequency was off so used GQRX to find the PPM Error (53). So I used sudo satnogs-setup to adjust Advanced > Radio > SATNOGS_PPM_ERROR intially to 53.0 and exited. After doing this no more observations. journalctl logs showed no activity. I reset this then to 53, same issue, then removed the SATNOGS_PPM_ERROR entry all together. Still no observations. Now when I run sudo satnogs-setup and ask for Support I get the same error

File “/user/lib/python3/dist-packages/apt/”, line 90 in__enter__ return self._lock._enter()
apt_pkg.Error: E:Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarly unavilable)

It looks like there is a file lock somewhere, not a permission issue.

A second lock error is also reported, this time on a directory /var/lib/apt/lists

It looks like that something broke when satnogs-setup was updating. Try to remove manually the lock by running:

sudo rm /var/lib/apt/lists/lock

After that try running again satnogs-setup, update and then apply changes. Just in case, every time you change a value like SATNOGS_PPM_ERROR, you need to hit apply and then exit from satnogs-setup.

I think I solved myself. I did a rm /var/lib/apt/lists/lock to remove the lock file, then the show command is working now.

decided to do a sudo apt-get update and see there is a liberspace:/satnogs/Rasbian_10 update? so I also did a sudo apt upgrade

so I am going to go back and set the PPM to 53 and see if it works.

1 Like

thanks your right. I figured out the rm too. should have looked before bugging you. sorry!

No problem :slight_smile:

1 Like