New station setup - what am I doing wrong?

Hello everyone,

I have been trying to setup my new ground station following the instructions from the wiki section. I have installed everything on the raspberry, I have created an account on network-dev and I am trying to schedule my first observation. However, when I connect to my ground station page (https://network-dev.satnogs.org/stations/220/) there is no new observation option. All I see, is an endless progress bar “Loading Pass Predictions”.
The same goes if I connect to other stations as well (e.g. https://network-dev.satnogs.org/stations/76/).
Moreover, if click from the top menu Observations and try to add a new observation for a NOAA satellite, once I click schedule I get an error “Please use the datetime dialogs to submit valid timeframe.”.

What am I missing? Is it me or is there something wrong with the https://network-dev.satnogs.org site?

Thanks

Hello @alexdem !

It could be a temporary issue with the -dev website. That said, we have opened up registrations for all stations on network.satnogs.org , so please do go ahead and move the station there (don’t forget the change in API key and ID on the client!)

Thanks for reporting, we will be looking into it and please reply here for any additional info/help you need.

@pierros thanks for the prompt reply!
I moved the station but still I get the same endless progress bar “Loading Pass Predictions”, so I cannot schedule my first observation :grimacing:
I will take a break for now and I will retry later!

PS I also changed the SATNOGS_NETWORK_API_URL

I just checked and it works pretty fine for me here! Are you sure it is not a browser issue? JS/cache?

You are right ! From my linux box Firefox Quantum does not show anything, however on my windows box everything seems to work as expected…
Sorry for the inconvenience…
Off for my first scheduled observation then :wink:

I am back with one more question. Regarding the LNA4ALL that I have installed before the RTL-SDR dongle, should I somehow let the system know, i.e. make the dongle power it?
I still cannot see anything worthy at my waterfalls… So prior to rechecking all my solderings, I wishfully think that maybe it has something to do with the LNA4ALL.

Thanks!

@alexdem How did you power the LNA4ALL?
If you are trying the Bias-T approach you need to do the BiasT Supply Modification (see here ) and then you need to make sure you have an SDR that can supply bias-t power (only the v3 from rtl-sdr.com does afaik for rtlsdrs) Even then you need to kick in a command to enable it.

I didn’t explicitly power it. I got the LNA4ALL with the extra Bias-T 3.3-5V mod so I guess I need the command to enable it (hopefully the rtl-sdr is v3). My original question was whether I should give an extra option on the sat-nogs setup, to enable the LNA4ALL powering. If there is no option on the sat-nogs setup, do you know what command I should give on my raspberry ?

Thanks once more

Nervermind, I found a how-to here:
https://www.rtl-sdr.com/rtl-sdr-blog-v-3-dongles-user-guide/

Hello again,

I am back with more questions/troubleshooting - I (believe that I) have done everything according to the wiki. So I have:

  • mounted the Turnstile antenna (SAT antenna TA-1 Turnstile)
  • connected the antenna (using a bought cable with the N-type and SMA) to an LNA4ALL
  • connected the LNA4ALL to the RTL-SDR (using a bought cable SMA/SMA)
  • connected the SDR to a raspberry pi

however, I am not sure I get the expected performance, i.e. I get this https://network.satnogs.org/observations/125240/ for NOAA 18 when I do not power the LNA4ALL
and this https://network.satnogs.org/observations/125576/ when I enable the power…

The only cable issue I can imagine is with the antenna connector - I soldered it myself but I think I did OK.
Also, I am using the wifi adapter of the Raspberry - does it add noise to the satellite signal?

Any suggestions or is this performance acceptable?

Thank you!!

I had a similar experience with the LNA4ALL with early experiments on my set up which is similar to yours. To isolate the issue I ensured that the rtl-sdr was away from the RPi (a 3m usb extension cable) and close to the antenna. I also took the LNA4ALL out of the system because it picked up all sorts of noise without adequate shielding (especially from the RPi).

You might get a load of other recommendations but it looks to me as though there isn’t enough signal getting in and my first step would be to strip it back to a minimal set up then build it up in bits to isolate any issues.

Alex

Alex, thank you for the input.

I’ll start testing with just the Antenna and the rtl-sdr connected to my laptop and I will add the components one at a time to find out what is going wrong.

I’ll get back with feedback!

It’s been a while but I’m back with feedback.
I initially removed completely the LNA4ALL and the reception was decent - at least for my standards. I then rechecked all the connections and re-installed the LNA4ALL. Moreover, I turned off the RPi wifi connection and kept only the Ethernet connection.
I tried both conditions of bias tee ON and OFF (rtl_biast -d 0 -b 1 and rtl_biast -d 0 -b 0 respectively) but I don’t get any better results (for all my tests I listen to NOAA APT). Am I doing something wrong? Should I physically install/change anything on the LNA4ALL?
I saw somewhere in the forum that I should “play” with the RF gain and some kind of tuning offset. I am not quite sure if this will make any difference, so if someone has any idea and some spare time, please help me :slight_smile:

I checked with the LN4ALL seller and he told my that If I enable the Bias-T power then it should work.
He said that I only have to Uncheck both AGC and adjust the RTL gain manualy.
Does this mean something to anyone?

Thank you

He said that I only have to Uncheck both AGC and adjust the RTL gain manualy.
Does this mean something to anyone?

Not sure what you are asking, but AGC is Automatic Gain Control. Which I guess is available in the RTL.SDR (have not received mine yet, so don’t know).

o/

Most RTLSDRs have AGC and most software turns it off by default because a moderately strong signal overdrives the ADC. I do not know if satnogs client is off by default. Appears from the waterfalls that you posted, you are not getting a signal to the RTLSDR. Since it appears to work better without the preamp, might be best to take it out of the circuit. The LNA4ALL that I purchased was defective on delivery.

You should get a partial decode, at least, from the NOAA sats with no preamp. If you are using a tracking antenna, maybe your antenna is not calibrated; ei: not pointing at the satellite. A very modest antenna that is properly tracking the NOAA sats should give very satisfactory results without a preamp.

Without the LNA4ALL I do get a partial image from ΝΟΑΑ.I will test the LNA4ALL on my windows machine using SDRSharp, to see if I can get amplification there. If not, maybe my LNA4ALL is also defective …

Thanks

with a stationary VHF/UHF bowtie scanner antenna, and no preamp, I get poor quality decodes, but usually a full map with fuzzy horizontal lines.

I run the RTLSDR at full gain with no preamp. But, I am using a poor antenna and 50 feet of used ten year old RG59 coax.

I think that tinkering with the RF gain contol might solve your problem.