Ground station map broken

When visiting a ground station page (ex: SatNOGS Network - Ground Station 1 ) using ipad or iphone, the map is no longer displayed.

Map can’t be rendered:
Your browser does not support MapboxGL (WebGL required).

Seems like some sort of regression; the map feature has worked before.

Hey @mfalkvidd

We have moved to mapbox-gl-js for quite some time now (over 2 years) and indeed one of the side effects is that older browsers with no WebGL support are not displaying the maps.

2 years? The maps worked for me about a week ago.
Not sure about what you mean by older browsers, my iphone and ipad are fully updated.

My two month iPad Pro failed to display the map for the first time today. Something just changed?

1 Like

hm… that’s strange, we haven’t done any change recently that should affect that part of the site. Unfortunately I don’t have an apple device to check. Maybe there will be an error in browser console but I don’t think it is easy to get it in iphone and ipad, maybe if this is reproduced on a mac we can find out.

Please also add details about the browser (which one) and its version. Thanks!

All browsers on iOS must use WebKit as rendering engine, per decree from Apple.

These are the versions installed on my ipad right now

Chrome: Mozilla/5.0 (iPad; CPU OS 13_5 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) CriOS/83.0.4103.88 Mobile/15E148 Safari/604.1

Safari: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1.1 Safari/605.1.15

Firefox: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1 Safari/605.1.15 lists which browsers support webgl lists which browsers support webgl 2.0.

I tried enabling webgl 2 in Settings - Safari - Experimental features and restarted Safari, but hat did not make the map appear. A reboot of the ipad did not make the map appear either.

I can install Safari on my PC later today to check if there are any messages in the console. shows a rotating cube on my ipad shows a map

(Both pages were linked from )

This happened once before. Satnogs Network Monitor

As mentioned in my one thread (Because i am also using webgl for stuff)

1 Like

Thanks @KD9KCK works fine on my ipad.

Does the Satnogs web site have some sort of change tracking? I searched amon the librespace repos on gitlab, but wasn’t able to find anything that looked like it could contain the web site.

I think I found it.

Yea two posts down if was found in that thread that something happened with the CSP back then. Thats why i linked it.

Satnogs Network Monitor is where the change that fix it that time was mentioned.

1 Like

I have created an issue:

1 Like

@mfalkvidd thanks for opening the issue. Can you also check the map at for example in

The map on db isn’t displaying on Chrome. ( Version 83.0.4103.116 (Official Build) (64-bit) On Windows 10) The maps on network do display properly for me on Chrome right now.

Console logs the following errors.

I can check the db map on my iOS device later today.

The map on is not visible on iphone or ipad, nor is it visible in Firefox 78.0.2 (64-bit) on Windows 7.

From the Firefox console: Content Security Policy: The page's settings blocked the loading of a resource at blob: ("script-src").

Under Chrome 83.0.4103.106 (OSX) I can’t load the map either:

mapbox-gl.js:33 Refused to create a worker from 'blob:' because it violates the following Content Security Policy directive: "script-src 'self' https://* 'unsafe-eval'". Note that 'worker-src' was not explicitly set, so 'script-src' is used as a fallback.

It’s also worth noting that I can see the map on station pages like and on

Please re-do your tests/checks using your available browsers against and and confirm that you can see the map fine. If everything works, soon we will deploy the changes in production, after finishing some other ongoing work.

Both dev sites look good on my ipad.


Was this ever fixed for production version? I’ve previously had this issue on Firefox, so I switched to Safari. Since this thread has started I’ve also had issues on all other browsers and devices. Any tips? I thought that it’s because of restrictive web browser or some adblock, but it happens on devices without any blocking as well. Thanks!