Beginner Help – Installing SatNOGS Client on Ras-Pi3

Hi everyone,
I’m fairly new to Raspberry Pi and I’ve run into a wall with installing the SatNOGS Client.

I’ve tried two different approaches. On one SD card I installed the NooB package, which seemed to work fine on its own, but whenever I would try to run the commands to install the Client in the command window it would fail.

On the other SD card I followed the steps here,  

Everything seems to be good up until: “4: Select “Apply” and the Raspberry Pi will configure itself; this may take some time”
When I tried to “Apply” each time the process would seem to work for a few minutes, then after the “Uninstall satnogs-client” got an “ok” it goes to “Install Satnogs-client” At this step it fails to install and after 5 attempts it cancels the process. I’ve tried this 3 times, always with the same result.
I’ve gone through this troubleshooting process, , the only issue I’m seeing is that I probably don’t have API configured correctly. Where do I find my API? On the stage environment I can see my station name, but not API. Station name is 204 – Denver_1
I’m not using SSH, could that be the problem?

Any ideas why I’m getting this error after the “Apply” step?  Also, how can I change my station to “Online” in the development stage?

Thank you,

Hi @Lowell – Off the top of my head, I’m not sure what might be going on with the problem you describe. It’s possible that you may find some hints by digging through /var/log – however, you might find it easier to download the Raspbian image built by the SatNOGS project and start with that. This the recommended way to get the client installed, and is probably a bit better tested.

As for the API key, that’s available in your user profile. On the stage environment, start at your station page; where it says “Owner”, click on your user name. On the page that comes up, you should see a button that says “API key”. Click that, and you’ll get the key. (I just realized that we don’t have those instructions on the wiki, so I’ll add those.)

Give those steps a try and let us know if you are still running into any problems. Good luck!

Thanks for the reply. I have the API now, but still getting the same error. I’ll try to download the image and see if that fixes things.

I was able to get the image to work from the link you sent me, then I was able to configure, update, and apply the client.

When I run the “journalctl -u satnogs-client.service” command I am not seeing what I should though. What I’m getting is this message several times per minute:
eXCEPTION: satnogs_station_id not configured
satnogs-client-service: Main process exited, code=exited, status=1/FAILURE
" " :Unit entered failed state.
" " :Failed with result 'exit code;

I have the station ID configured as: 204 - Denver_1

Also, I am still offline on the stage environment ground station page. However, the “Is it operational?” checkbox in on the groundstation page that the troubleshooting guide refers to, where is that?

I changed Station ID to 204, now it looks like we’re online.



Hey @Lowell – glad to hear things are working for you! And thanks for reporting back about what’s wrong – this definitely helps show where the documentation needs to be improved.